آموزش نصب برنامه در لینوکس

آموزش نصب برنامه در لینوکس (چگونه در لینوکس برنامه نصب کنیم)

همانطور که میدانید برای نصب نرم افزار در ویندوز کار خاصی را نباید انجام دهید تنها احتیاج به فایل نصبی برنامه دارید و کافیست با دو بار کلیک بر روی فایل Setup مراحل نصب نرم افزار شروع شود، اما در لینوکس این فرایند کاملا متفاوت میباشد در لینوکس دیگر محیط گرافیکی برای نصب نرم افزار ها وجود ندارد و شما باید از ابزار Terminal یا به واژه ای همان CMD ویندوز در لینوکس استفاده کنید (البته برا خود لینوکس نه ویندوز 🙂 ) همراه با تی ام ال منیجر باشید تا مراحل نصب را شروع کنیم

پیشنهاد: در صورت علاقه به یادگیری حرفه ای Linux از صفحه آموزش کامل Linux استفاده کنید. همچنین در صورت علاقه به یادگیری Ubuntu از آموزش کار با سیستم عامل Ubuntu استفاده کنید.

در این آموزش ما میخواهیم نرم افزار Google Chrome را در توزیع UBUNTU نصب کنیم که یکی از معروفترین توزیع های لینوکس میباشد.

برای شروع ابتدا فایل نصبی Google Chrome را از سایت گوگل دریافت کنید (لینک دانلود گوگل کروم برای LINUX) پس از کلیک بر روی لینک روی گزینه Download Chrome For another platform کلیک کنید سپس روی گزینه Linux کلیک کرده و در آخر روی گزینه متناسب به توزیع خود کلیک کنید و سپس روی گزینه Accept And Install کلیک کنید.

Google Chrome Setup File For Ubuntu X64

بعد از دانلود فایل Google Chrome برنامه Terminal را اجرا کنید سپس باید با دستور cd به دایرکتوری بروید که فایل تان در آنجا دانلود شده در این مثال برای من به پوشه Download رفته سپس از دستور dpkg و پارامتر -i برای نصب استفاده کنید همچنین دستور sudo (همان Run As Administrator ویندوز) را قبل از دستور dpkg برای دادن مجوز مدیریت به نصب استفاده کنید در غیر این صورت برنامه نصب نخواهد شد. به مثال توجه کنید:

cd Downloads
sudo dpkg -i google-chrome-stable_current_amd64.deb

sudo-dpkg--i-application

فرایند نصب نصب نرم افزار در لینوکس

  • با دستور sudo مجوز گرفته سپس دستور نصب یعنی dpkg را با پارامتر –i وارد میکنیم
  • سپس نام فایل نصبی برنامه را وارد میکنیم مثلا: google-chrome-stable_current_amd64.deb
  • در آخر در صورت پرسش باید رمز عبور حساب کاربری خود را وارد کنید.

نکته: همه حروف باید کوچک باشند چون در لینوکس حروف بزرگ و کوچک متفاوت است.

همچنین میتوانید بدون دانلود کردن یک برنامه آن را نصب کنید کافیست تا نام برنامه را بدانید مثلا برای نصب نرم افزار VLC Player باید نام نرم افزار را بعد از دستور apt-get install وارد کرده برای مثال:

sudo apt-get update
sudo apt-get install vlc

sudo-apt-get-install-application

در مثال بالا دستور apt-get install برنامه VLC Player را از repository (منبع) های Ubuntu دریافت کرده و سپس آن را نصب میکند.

نکته: نام برنامه را باید دقیق و بدون اشتباه وارد کنید در غیر این صورت با خطا مواجه میشوید. یا میتوانید چند حرف اول برنامه را وارد کرده سپس کلید Tab را از روی کیبورد بفشارید تا نام برنامه به صورت کامل نوشته شود.

همچنین میتوانید از دستور apt-get برای حذف برنامه ها استفاده کنید کافیست تا پارامتر purge بعد از دستور apt-get بیاورید سپس نام برنامه مورد نظر را بنویسید برای مثال:

sudo apt-get purge vlc
sudo apt-get autoremove

چگونه در لینوکس برنامه نصب کنیم

در مثال بالا با دستور apt-get و پارامتر purge برنامه vlc را به صورت حذف نموده ایم سپس از پارامتر autoremove با دستور apt-get برای حذف فایلهای وابسته برنامه استفاده میکنیم.

بروز رسانی برنامه ها در لینوکس

برای بروز رسانی برنامه ها باید از همان دستور apt-get با پارامتر dist-upgrade استفاده کنید اما قبل از آن باید دستور apt-get را با زیر دستور update وارد کنید برای مثال:

sudo apt-get update

sudo apt-get dist-upgrade

در صورتی که به خطا یا مشکلی برخوردی اگه پیامش رو برام ارسال کنی احتمال زیاد بتونم بهت کمک کنم 🙂 اگه دوست داشتی یاااااااااااااااااااا


برای دریافت نسخه PDF مقاله های سایت ابتدا در سایت ثبت نام کنید تا بتوانید به کلیه مقالات به صورت کاملا رایگان دسترسی پیدا کنید. ورود به سایت | ثبت نام در سایت

 

به نظر شما ممکنه کسی با استفاده از کلید های زیر این مطلب رو به اشتراک بذاره؟
محمد برغمدی

محمد برغمدی

امام علی علیه السلام: با مردم آنگونه معاشرت كنيد، كه اگر مرديد بر شما اشك ريزند، و اگر زنده مانديد، با اشتياق سوي شما آيند.

90 دیدگاه روی “آموزش نصب برنامه در لینوکس

  • دسامبر 18, 2015 در 14:02
    Permalink

    سلام.
    پسورد فایلها چی هست؟

    پاسخ
  • ژانویه 28, 2016 در 18:24
    Permalink

    با سلام
    ممنون مقاله خوبتان
    من در اوبونتو کاملا مبتدی هستم و می خواهم ابزار کلدی( kaldi tookit) را نصب کنم و تمام مواردی که در سایتها و از جمله مقاله شما میباشد را امتحان کردم و در نهایت این جواب را به من می دهد.
    Some index files failed to download. They have been ignored, or old ones used instead
    به کمک یکی از دوستان تو سایتی دیگر کد های زیر را پشت سرهم زدم

    sudo cp /etc/apt/sources.list ~/
    sudo wget “http://pastebin.com/raw.php?i=uzhrtg5M”; -O /etc/apt/sources.list
    sudo apt-get update
    sudo rm /etc/apt/sources.list.d/ubuntu-extras.list
    sudo apt-get update
    باز همان جواب را به من میدهد
    لطفا کمکم کنید

    پاسخ
      • ژانویه 29, 2016 در 10:58
        Permalink

        با سلام و تشکر
        ubuntu13.04 Desktop Edition
        چند نرم افزار دیگر را هم امتحان کردم برای نصب . اما به همین مشکل برخورد کردم.
        ممنون می شوم که کمکم کنید.

        پاسخ
        • محمد برغمدی
          ژانویه 29, 2016 در 13:29
          Permalink

          سلام
          این مشکل به دلیل قدیمی بودن پیکربندی منابع (/etc/apt/sources.list) سیستم عامل شماست.
          راه حلش همون به روز کردن sources.list بود که در سایت قبلی بهتون گفته بودن – اما راه حل قبلی برای نسخه ۱۲.۰۴ بود نه نسخه ۱۳.۰۴ . شما باید از نسخه جدید UBUNTU استفاده کنید (Ubuntu 15.10) در اصطلاح نسخه شما به دوره EOL خودش رسیده. و براش دیگه آپدیتی نمیذارن.
          باز هم اگه هر سوالی داشتی ما رو از محبت خودت دریغ نکن با تشکر.

          پاسخ
          • ژانویه 29, 2016 در 14:24
            Permalink

            با سلام و ممنون از پاسخ تون .ممنون می شوم که امروز آنلاین باشید . مشکلی دیگری داشتم از شما بپرسم.در حال حاضر در حال دانلود نسخه 10-15 هستم . از سوالتان حدس زدم که مشکلم همین باشد . آیا باید حتما لینوکس قبلی را remove کنم ؟
            باز هم از جوابتان تشکر می کنم.

          • محمد برغمدی
            ژانویه 29, 2016 در 15:43
            Permalink

            سلام
            خیر اگه به نسخه قبل نیاز داری میتونی نگهش داری و روی یک پارتیشن دیگه نسخه جدید رو نصب کنی.
            خواهش میکنم.

  • می 6, 2016 در 17:01
    Permalink

    سلام متشكرم از مطالب مفيدتون
    داداش من ميخوام تو ترمينال c9.io براي ساخت ربات ضداسپم نصب كنم نصب كردم ولي بعضي ارور هارو ميده ميتونين كمك كنين ؟

    پاسخ
  • می 9, 2016 در 19:03
    Permalink

    سلام دوستان ! نمیدونم جاشه یانه اما من مشکل کمی متفاوت تر دارم مشکلم اینه که روی تایلز که از رو یکی از توزیعهای لینوکس ساخته شده و یک سیستم عامل لایو هستش و با یواس بی بدون نصب اجرا میشه چه جوری اپلکیشن مودم یواس بس ام را نصب کنم که بتونم به اینترنیت وصل بشم و شما که میدونید تایلز برای اتصال با اینترنت برای ناشناس ماندن ساخته شده و بدیل برای تور هستش

    پاسخ
  • ژوئن 25, 2016 در 14:53
    Permalink

    سلام من دستور su میزنم پسورد میخاد این پسورد چیه؟ در حین نصب من فقط یه پسورد دادم که هنگام ورود از من میخاد و اون پسورد نیست

    پاسخ
    • محمد برغمدی
      ژوئن 25, 2016 در 23:51
      Permalink

      سلام امیررضا جان
      دستور su رو با نام هر حساب کاربری که وارد کنی باید رمز همون حساب رو وارد کنی برای مثال:
      su root
      هر رمزی که برای root گذاشتی همون رمز.

      پاسخ
  • آگوست 23, 2016 در 12:23
    Permalink

    سلام مقاله خوبی بود و کمکم کرد ولی من تو چند تا سایت دیگه هم جستجو کردم. من تازه لینوکس ابونتو 14.10 رو نصب کردم. مشکل من اینه که وقتی دستور
    sudo apt-get install clamav
    رو میزنم این پیغام رو به من میده:
    reading package lists… Done
    Building dependency tree
    Reading state information… Done
    E: Unable to locate package clamav

    پاسخ
    • محمد برغمدی
      آگوست 23, 2016 در 15:28
      Permalink

      سلام امیر حسین جان
      پکیجی که میخوای نصب کنی در Repository ابونتو وجود نداره، به همین خاطر بهت خطا نشون میده
      باید اول PPA مربوط رو به Clamav رو اضافه کنی بعد دوباره با دستور بالا اقدام به نصبش کنی
      یا اینکه فایل نصبی Clamav.deb رو از اینترنت دانلود کنی بعد با دستور dpkg -i clamav شروع به نصبش کنید.
      گزینه اول بهتره چون آنتی ویروس نیاز به بروز رسانی هم داره که باز به مشکل بر میخوری

      پاسخ
      • آگوست 23, 2016 در 15:34
        Permalink

        خیلی ممنون که جواب دادید.
        این موضوع درباره تمامی نرم افزار ها صدق میکنه؟ اخه من هر نرم افزاری که خواستم با این روش نصب کنم بهم همین ارور رو داده
        بازم ممنون

        پاسخ
        • محمد برغمدی
          آگوست 23, 2016 در 16:04
          Permalink

          نسخه UBUNTU که استفاده میکنید دیگه پشتیبانی نمیشه
          اما دستورات زیر رو تست کنید شاید جواب گرفتید. (کلا شک دارم چون نسخه موقت رو دارید که فقط 6 تا 12 ماه پشتیبانی میشه و از تاریخش 1 سال گذشته)
          sudo add-apt-repository main
          sudo add-apt-repository universe
          sudo add-apt-repository restricted
          sudo add-apt-repository multiverse
          sudo apt-get update
          sudo apt-get install clamav
          اگر از نسخه های LTS استفاده کنید بهتره چون معمولا تا 5 سال پشتیبانی میشن
          نسخه جدید UBUNTU رو از سایتش دریافت کنید بعد برنامه Clamav رو نصب کنید.

          پاسخ
          • آگوست 23, 2016 در 21:36
            Permalink

            ممنون از راهنماییتون

          • محمد برغمدی
            آگوست 23, 2016 در 22:38
            Permalink

            خواهش میکنم 🙂
            ممنونم میشم اگه باز هم سوالی داشتید تی ام ال منیجر رو از محبت خودتون دریغ نکنید.

          • آگوست 27, 2016 در 07:49
            Permalink

            سلام و خسته نباشید!
            من اوبونتو رو به نسخه 16.04 LTS آپدیت کردم همونطور که خودتون گفتید. حالا این پیغام رو در جواب دستور sudo apt-get update و بقیه دستورات از این خانواده میده. ارور:
            E: Could not get lock /var/lib/apt/lists/lock – open (11: Resource temporarily unavailable)
            E: Unable to lock directory /var/lib/apt/lists/
            E: Could not get lock /var/lib/dpkg/lock – open (11: Resource temporarily unavailable)
            E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

          • آگوست 27, 2016 در 09:21
            Permalink

            آقا ممنون درست شد واقعا ازتون ممنونم که وقت میذارید و با صبر راهنمایی می کنید 🙂

          • محمد برغمدی
            آگوست 27, 2016 در 13:48
            Permalink

            سلام
            خواهش میکنم امیر حسین جان، باعث خوشحالی که شما رو راضی میبینم؟

  • سپتامبر 15, 2016 در 02:19
    Permalink

    سلام و خدا قوت
    من ابونتو 16.04 رو نصب کردم ، میخواستم این دستور sudo apt-get install gcc-C++ python رو اجرا کنم ولی با خطای زیر مواجه شدم:
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    E: Unable to locate package gcc-C+
    E: Couldn’t find any package by regex’gcc-C+’

    ممنون میشم راهنمایی کنید که چکار کنم؟
    در ضمن از مقاله و بیان خوبتون متشکرم…

    پاسخ
    • محمد برغمدی
      سپتامبر 15, 2016 در 08:06
      Permalink

      سلام دوست عزیز
      ممنونم از لطف تون 🙂
      معمولا علت اصلی این خطا نبود برنامه مورد نظر در Repository توزیع مورد استفاده شماست.
      برای رفع مشکل باید PPA مربوط به برنامه رو در توزیع لینوکس اضافه کنید.
      لطفا اسم برنامه ای که میخواهید نصب کنید رو بگید

      پاسخ
      • سپتامبر 15, 2016 در 11:47
        Permalink

        من در لینکوس مبتدی هستم ولی همینایی که گفتید رو هم دستوراتی از اینترنت پیدا کردم و اجرا کردم ولی متاسفانه باز همین خطا رو میگرفت…
        من میخوام نرم افزار NS3 رو نصب کنم برای پشتیبانی از زبان C++ گفتن که این دستور رو باید بزنم، البته چند دستور دیگه هم هست که برا اونا هم مشابه این خطا رو میگرفت…
        ممنون از وقتی که میگذارید…

        پاسخ
        • محمد برغمدی
          سپتامبر 15, 2016 در 14:03
          Permalink

          برای نصب ns3 دستورات زیر رو وارد کنید:
          sudo apt-get update
          sudo apt-get install ns3
          برای پشتیبانی از C++ از دستور زیر استفاده کنید:
          apt-get install gcc g++ python
          آموزش نصب ns3 و پشتیبانی از C++ رو به صورت کامل در سایت اصلیش توضیح داده

          پاسخ
        • محمد برغمدی
          سپتامبر 15, 2016 در 14:05
          Permalink

          تو نصب برنامه های دیگه هم مشکل دارید؟ یا فقط همین ns3 رو نمیتونید نصب کنید؟

          پاسخ
          • سپتامبر 15, 2016 در 15:16
            Permalink

            خیلی ممنون بابت راهنمایی هاتون و اینکه سریع پاسخ میدید …
            فعلا اولین کارم هست که با لینوکس کار میکنم و قرار بود که همین ns-3 رو نصب کنم…

  • سپتامبر 22, 2016 در 14:53
    Permalink

    سلام
    من وقتی کد نصب نرم افزار software-center رو تو ترمینال میزنم اینو نشون میده

    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Package software-center is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source

    E: Package ‘software-center’ has no installation candidate

    ممنون میشم بگی مشکل از چیه.

    پاسخ
    • محمد برغمدی
      سپتامبر 22, 2016 در 18:45
      Permalink

      سلام میلاد جان
      احتمال زیاد Repository توزیع تون پاک یا خراب شده به همین خاطر دستور apt-get نمیتونه چیزی رو پیدا کنه
      اگه از UBUNTU استفاده میکنی یک فایل sources.list در ادرس /etc/apt درست کنید و محتوای فایل متن این صفحه رو در sources.list پیست کنید.
      بعد دوباره تست بگیرید.
      به آموزش مخازن لینوکس هم مراجعه کنید شاید کمکتون کرد.
      موفق باشید.

      پاسخ
  • دسامبر 1, 2016 در 01:02
    Permalink

    سلام مرسی ازمقاله خوبتون وتشکر از وقتی که برامون میگذارین
    من همین کاری که شما گفتین وانجام دادم در نصب wine ولی اخطار میده
    david@david-Lenovo-IdeaPad-Z510:~$ cd Downloads/
    david@david-Lenovo-IdeaPad-Z510:~/Downloads$ sudo dpkg -i wine-1.9.24/
    [sudo] password for david:
    Sorry, try again.
    [sudo] password for david:
    dpkg: error: dpkg status database is locked by another process

    پاسخ
  • محمد برغمدی
    دسامبر 1, 2016 در 07:15
    Permalink

    سلام خواهش میکنم 🙂
    فکر میکنم چند تا برنامه مربوط به نصب و یا بروز رسانی رو با هم اجرا کردید یا اینکه نگذاشید کار برنامه قبلی به پایان برسه و یک برنامه دیگه رو هم روی نصب گذاشتید.
    تو لینوکس نمیشه در آن واحد چند برنامه رو همزمان نصب کرد مثلا یکی از طریق Synaptic Package Manager یکی دیگرو از طریق دستور Dpkg یا مثلا نمیشه هم سیستم عامل رو بروز رسانی کنید هم برنامه نصب کنید.
    اول سیستم رو ریستارت کنید بعد دستورات زیر رو در Terminal وارد کنید:
    sudo rm /var/lib/dpkg/lock
    sudo dpkg –configure -a
    بعد از وارد کردن دستورات بالا مشکل Lock شدن Database حل میشه و دوباره میتونی شروع به نصب برنامه wine کنی

    پاسخ
  • دسامبر 20, 2016 در 12:39
    Permalink

    ایول خسته نباشید فقط ممنون میشم که ادامه بدین و انشاااله بشین مرجع کامل و اصلی لینوکس به زبان فارسی یاحق

    پاسخ
  • ژانویه 10, 2017 در 13:53
    Permalink

    سلام
    مرسی ازمقاله خوبتون وتشکر از وقتی که برامون میگذارین.
    من اوبونتو رو در محیط بوت نصب کردم و به خوبی کار میکنه ولی برای نصب برنامه ها (همه ی برنامه ها )وقتی دستور رو در ترمینال وارد میکنم مثلا این:
    sudo apt-get purge vlc
    بعد از اینکه بسورد رو وارد میکنم برای نصب و دانلود و ابدیت تمام برنامه ها این میاد
    E: Malformed entry 55 in list file /etc/apt/sources.list (URI parse)
    E: The list of sources could not be read.
    E: Malformed entry 55 in list file /etc/apt/sources.list (URI parse)
    E: The list of sources could not be read.

    چیکار کنم لطفا کمکم کنید منتظرم
    اینم عکس از ترمینال

    http://uupload.ir/files/832d_screenshot_from_2017-01-10_13-43-08.png

    این هم جیمیلم

    omidobunto1604@gmail.com

    پاسخ
    • محمد برغمدی
      ژانویه 10, 2017 در 22:50
      Permalink

      سلام امید جان
      احتمال زیاد به Repository منابع خراب یا تاریخ انقضا گذشته اضافه کردی باید با دستور gedit یا یک برنامه ویرایش متن دیگه فایل source.list رو ویرایش کنی بعد در کنار منابع تاریخ گذشته یا Third Party علامت # بزاری تا این منابع رو غیر فعال کنید.
      تو ترمینال باید دستور زیر رو وارد کنید:
      sudo gedit /etc/apt/sources.list
      سر هر خط یک علامت # بزار

      پاسخ
  • ژانویه 11, 2017 در 14:22
    Permalink

    سلام مجدد !
    خیلی ممنونم از باسخی که بهم دادید
    من فرمایش شما رو انجام دادم و توی ترمینال دستور sudo gedit /etc/apt/sources.list رو وارد کردم و یه لیستی برام باز شد سر هر خط علامت # رو گذاشتم و در اخر اون و سیو کردم و بعد در داخل ترمینال این اومد !
    (gedit:3573): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

    ** (gedit:3573): WARNING **: Set document metadata failed: Setting attribute metadata::gedit-spell-enabled not supported

    ** (gedit:3573): WARNING **: Set document metadata failed: Setting attribute metadata::gedit-encoding not supported

    ** (gedit:3573): WARNING **: Set document metadata failed: Setting attribute metadata::gedit-spell-enabled not supported

    ** (gedit:3573): WARNING **: Set document metadata failed: Setting attribute metadata::gedit-encoding not supported

    ** (gedit:3573): WARNING **: Set document metadata failed: Setting attribute metadata::gedit-position not supported
    اینم عکسش:
    http://uupload.ir/files/e7kf_screenshot_from_2017-01-11_14-12-24.png
    و بعدش از این وقتی دستور:
    sudo apt-get purge vlc را وارد ترمیناکردم دیگه نوشته قبلی نیومد و بجاش این اومد!
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    E: Unable to locate package vlc
    اینم عکسش:(دو تا عکسا یکی هست )
    http://uupload.ir/files/e7kf_screenshot_from_2017-01-11_14-12-24.png
    ممنون

    پاسخ
    • محمد برغمدی
      ژانویه 12, 2017 در 05:05
      Permalink

      علیک سلام
      من نگفتم جلوی همه سطر ها علامت # بزار تا غیر فعال شن منظورم همون سطر 55 بود که برات مشکل درست کرده بود.
      در کل مشکلی نیست میتونی دوباره ویرایش کنی و علامت های # اضافی رو حذف کنید یا اینکه یک راه ساده تر هم وجود داره اونهم حذف کلی فایل sources.list و ساخت مجدد این فایل از طریق برنامه software-properties-gtk است.
      اول با دستور rm فایل source.list رو حذف کن:
      sudo rm /etc/apt/sources.list
      بعد از حذف فایل باید برنامه software-properties-gtk رو اجرا کنید:
      sudo -i software-properties-gtk
      بعد از اجرای برنامه مدیریت Repository تیک گزینه اول و دوم رو بزار و از بخش Download From سرور کشور ایران یا هر کشور دیگه ای رو انتخاب کن، بعد از تب Update بررسی کن تا گزینه اول و دوم تیک داشته باشند.
      در آخر با دستور sudo apt-get update و sudo apt-get upgrade توزیع لینوکس رو بروزرسانی کن

      پاسخ
  • فوریه 7, 2017 در 23:30
    Permalink

    سلام و خسته نباشید.
    من برنامه booksim رو می خوام تو آبونتو نصب کنم ، از سایت https://github.com/booksim دانلود کردم ، فایل دانلودی زیپ می باشد.
    در ابتدا باید تغییری در فایل دانلودی ایجاد کنم ؟ اکسترکت و … ؟
    دوم کد بالا رو که فرمودید انجام می دهم ارور زیر را می دهد ، لطفا کامل راهنمایی کنید ، من تا حالا با لینوکس کار نکردم
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    E : unable to locate package booksim2-master
    از بابت آموزش هایتان هم صمیمانه سپاسگذارم.
    ممنون و موفق باشید.

    پاسخ
    • محمد برغمدی
      فوریه 8, 2017 در 16:14
      Permalink

      سلام امین جان
      فایل نصبی شو دانلود کردی؟ بعد از دستور apt-get install برای نصبش استفاده کردی؟
      ببین اگر فایل Setup برنامه رو گرفته باشی که معمولا با فرمت .deb یا .rpm باید با دستور sudo dpkg -i packagename.deb نصبش کنید. در غیر این صورت اگر میخوای فایل رو به صورت مستقیم با دستور sudo apt-get install نصب کنید باید package برنامه شما تو repository توزیع ubuntu شما باشه در غیر این صورت با همین مشکل بالا برخورد میکنید.
      موفق باشید.

      پاسخ
  • فوریه 8, 2017 در 17:05
    Permalink

    سلام.
    فایل نصبی که دانلود کردم هیچ کدوم از فرمت هایی که گفتید رو نداره ، یه چند تا پوشه است که یه سری اطلاعات داخلشه
    اونا هم چنین فرمتی رو ندارن.
    طبق فرمایش شما هم فکنم روش دوم هم امکان پذیر نیست ، چون پکیج در توزیع ابونتو نیست.
    لطفا بفرمایید چی کار کنم ؟
    فایل نصبی هم می گردم تو اینترنت نیست یا من پیدا نمی کنم !

    ممنون و موفق باشید.

    پاسخ
    • محمد برغمدی
      فوریه 9, 2017 در 14:59
      Permalink

      سلام
      من فکر میکنم این فایلی که از سایت Github دریافت کردید فقط فایل پروژه Booksim باشه و باید با یک برنامه دیگه اجراش کنید. (Simulator)
      توضیحات کامل Booksim رو میتونید از اینجا دریافت کنید.

      پاسخ
  • فوریه 9, 2017 در 18:19
    Permalink

    سلام.
    مرسی ، حتما بررسی می کنم.

    ممنون و موفق باشید.

    پاسخ
  • فوریه 16, 2017 در 14:41
    Permalink

    sudo dpkg -i google-chrome-stable_current_amd64.deb
    dpkg: error: dpkg status database is locked by another process
    baraye nasb barname chorom in error o be mn dad chi karesh konm?

    پاسخ
  • فوریه 17, 2017 در 01:53
    Permalink

    سلام
    آیا میشه نرم افزار Microsoft Visual C# رو روی Ubuntu نصب کرد؟ اگر میشه لطفا لینک دانلود رو بدید
    ممنون میشم

    پاسخ
    • محمد برغمدی
      فوریه 17, 2017 در 07:06
      Permalink

      سلام
      منظور شما از Microsoft Visual C# همون Microsoft Visual Studio برای نوشتن برنامه است؟ (محیط برنامه نویسی)

      پاسخ
  • فوریه 17, 2017 در 09:36
    Permalink

    Bale hamon mikhstm bedonm mishe Microsft visual stodio C# ro roye linux nasb kard va barname nevisi kard ya khair fht baraye windowse? Ahe baraye linux ham hast bi zahmat rahnamyee konid ke az koja download konm va file rahnamaye nasbesh o bi zahmt lootf konid bedid mamnoon mishm

    پاسخ
    • محمد برغمدی
      فوریه 17, 2017 در 09:58
      Permalink

      نرم افزار Microsoft Visual Studio اصلی رو نمیشه نصب کرد چون مخصوص خود ویندوز حتی با Wine هم نمیشه توی لینوکس اجراش کنید. ولی میتونید از ویرایشگر کد Microsoft Visual Studio Code استفاده کنید.
      Visual Studio Code یک IDE کامل نیست ولی جایگزین مناسبی برای Microsoft Visual Studio در توزیع های لینوکس محسوب میشه.
      برای اطلاعات بیشتر آموزش نصب Visual Studio Code در لینوکس رو بخونید.

      پاسخ
  • فوریه 17, 2017 در 10:54
    Permalink

    ahan khaily mamnoon
    khaily mofid bood amozeshesh ey lkas fght pdfesh mizashtid ke beshe dl kard o file ro backup dashte bashim age betonid pdfeshm bezarid khaily khob mishe
    vali siteton vaghean aliii hast va pasokhgooyitonm 20 dmt garm:)

    پاسخ
  • فوریه 25, 2017 در 04:07
    Permalink

    با سلام
    واقعا ممنون بابت این مطلب,‌ بنده هم برای اولین بار فقط چند ساعت Ubuntu رو نصب کردم و درموقع نصب نرم افزارها این آموزش شما خیلی خیلی کمکم کرد.
    فقط یک مطلبی که هنوز متوجه نشده ام اینه که, من معمولا برای نصب برنامه ها فایل Setup‌ رو خودم دانلود میکنم و از روی اون شروع به نصب میکنم, برای اینکه اگه بعدا مجبور به نصب مجدد لینوکس شدم لازم نباشه مجددا همه نرم افزارهای مورد نیازم رو دانلود کنم;
    خب حالا محمد عزیز,‌ سوال من این هستش که با این روش نصب بنده که از روی فایل Setup هستش. اگه آپدیتی برای برنامه نصب شده بیاد, نرم افزار Ubuntu Software میتونه آپدیت جدید رو برای اون نرم افزار هم انجام بده و یا کلا اون نرم افزار رو می تونه مدیریت کنه یا حتما باید توسط خودش دانلود و نصب شده باشد ؟
    سوال دوم هم اینکه اگه از خودت Repository یا ترمینال(apt-get) نرم افزارها رو دانلود و نصب کنم اونوقت امکانش هست که فایل Setup‌ دانلود شده رو کپی کنم و نگه دارم ؟

    ببخشید سوالم طولانی شد,‌ پیشاپیش از شما سپاسگذارم

    پاسخ
    • محمد برغمدی
      فوریه 25, 2017 در 09:16
      Permalink

      سلام محمد جان
      از لحاظ بروز رسانی و مدیریت نرم افزار توسط توزیع لینوکس هیچ فرقی با دریافت نرم افزار از مخازن لینوکس نیست
      به صورت پیشفرض هم محل ذخیره یا آرشیو فایلهای نصبی در آدرس /var/cache/apt/archive
      خواهش میکنم، موفق و سربلند باشید.

      پاسخ
      • فوریه 27, 2017 در 10:01
        Permalink

        یک دنیا تشکر از لطف و راهنمایی شما؛
        پوزش میخوام یک مشکلی هم برام پیش اومده نمیدونم جایز هست اینجا بپرسم یا خیر.
        من توی Menubar یا Titlebar دوتا از Notification ها می بینم! (همون نمایش ساعت و شبکه و …) نمیدونم اسم این نوار چی هست بخاطر همین هرچی گوگل کردم به جایی نرسیدم، توی تصویری که آپلود کردم میتونی مشاهده کنید:
        http://2.1m.yt/xKKubmq.png

        ممنون میشم در صورت امکان راهنمایی فرمایید.

        با تشکر

        پاسخ
        • محمد برغمدی
          فوریه 27, 2017 در 10:25
          Permalink

          خواهش میکنم 🙂
          از دستور زیر استفاده کن احتمالا مشکلش برطرف بشه
          dconf reset -f /org/gnome/gnome-panel/layout/
          بعد از وارد کردن دستور سیستمت رو ریستارت کن اگر مشکل باز هم پا برجا بود این دستور رو هم تست کن:
          mv ~/.gconf/apps/panel ~/gnome-panel-backup
          gnome-panel –replace &
          برای پرسش سوالات مربوط به توزیع Ubuntu از پست آموزش کار با Ubuntu استفاده کن
          ممنونم 🙂

          پاسخ
          • فوریه 27, 2017 در 11:16
            Permalink

            باز هم ممنونم محمد جان;
            پس مربوط به Gnome‌ میشد.
            دستور دومی که گفتی مشکل رو برطرف کرد, واقعا متشکرم.
            فقط برای دوستانی که احیانا با مشکل مشابه من مواجه شده اند این رو اضافه میکنم که, اول باید gnome-panel نصب باشه, بعد این دستور که گفتید مشکل رو برطرف میکنه:

            mv ~/.gconf/apps/panel ~/gnome-panel-backup & gnome-panel –replace &

            محمد جان شما تو این ابتدای راه لینوکس برای بنده حکم یک معلم رو داری, بسیار ممنونم ازت.

            تشکر فراوان

          • محمد برغمدی
            فوریه 27, 2017 در 11:44
            Permalink

            خواهش میکنم، من از شما ممنونم که اطلاعات تکمیلی رو اضافه کردید.
            من مخلصتم، ان شا الله همیشه سر بلند و موفق باشید.

  • فوریه 28, 2017 در 16:19
    Permalink

    گوگل کروم رو مستقیم از سایت دانلود کردم و با دستور chmod + نصب کردم چنتا ارور داد بعدش دستور apt-get -f install رو زدم بعد دوباره نصب کردم ارور خاصی نداد رفتم تو قسمت ابلیکیشن ها جستجو کردم کروم ایکونش هست ولی کیلیک میکنم اتفاقی نمی افته.نمیدونم این دستورات ربطی به هم داشتن یا نه ! تازه واردیم دیگه شما ببخشید ما رو 🙂

    پاسخ
    • فوریه 28, 2017 در 16:22
      Permalink

      ببخشید کروم رو با دستوری که خودتون گفتید dpkg -i زدم.

      پاسخ
    • محمد برغمدی
      مارس 1, 2017 در 07:54
      Permalink

      سلام
      فایل پیکربندی Chrome رو حذف کنید تا دوباره درستش کنه
      برای اینکار میتونید از دستور rm استفاده کنید. برای مثال:
      rm ~/.config/google-chrome/*
      کافیه دستور بالا رو کپی پیست کنید.

      پاسخ
  • مارس 5, 2017 در 19:04
    Permalink

    ببخشید من میخوام websploit رو تو linux نصب کنم میشه راهنمایی کنید؟

    پاسخ
    • محمد برغمدی
      مارس 6, 2017 در 04:15
      Permalink

      سلام از چه توزیعی استفاده میکنید؟
      دستور نصب websploit:
      sudo apt-get install websploit

      پاسخ
  • مارس 19, 2017 در 18:38
    Permalink

    سلام خسته نباشید میشه کمک کنید من میخوام atom editor روی سیستم عامل رزبررین که بر پایه دبیان هست و برای برد های رزپری پای سااخته شده با همچین اروری مواجه میشم کمک کنید
    sudo dpkg -i atom-amd64.deb
    dpkg: error processing archive atom-amd64.deb (–install):
    package architecture (amd64) does not match system (armhf)
    Errors were encountered while processing:
    atom-amd64.deb

    پاسخ
    • محمد برغمدی
      مارس 19, 2017 در 20:15
      Permalink

      سلام ایمان جان
      در خطایی که ارسال کردید گفته شده برنامه atom-amd64.deb با نوع سیستم عامل شما هماهنگی نداره چرا که شما احتمالا دارید از Chrombook یا NoteBook استفاده کنید.
      برای رفع این مشکل باید Atom Editor مربوط به سیستم خودتون رو نصب کنید.
      برای دریافت اطلاعات بیشتر به سایت Github مراجعه کنید: #7822

      پاسخ
  • مارس 27, 2017 در 12:01
    Permalink

    سلام دوستان
    من برای اولین بار هست که با اوبونتو کار می کنم.
    بنده فایل QCApro_1.1-1.tgz از سایت https://cran.r-project.org/web/packages/QCApro/index.html دانلود کرده ام
    حال می خواهم با این نرم افزار کار کنم.
    ولی نمی توانم کار کنم.
    نحوه نصب این فایل به چه صورت است.

    لطفاً راهنمایی نمایید
    لازم به ذکر است، از طریق همین انجام آموزش چگونه نصب نرم افزار را مشاهده کردم. ولی متوجه نشده ام.

    باتشکر

    پاسخ
    • محمد برغمدی
      مارس 29, 2017 در 20:54
      Permalink

      سلام
      فایل مورد نظر شما Setup یک نرم افزار نیست که بخواهید اون رو در Ubuntu نصب کنید.
      یک فایل Archive که احتمالا باید با یک برنامه جداگانه اجرا بشه.
      موفق باشید.

      پاسخ
  • مارس 28, 2017 در 03:39
    Permalink

    سلام و خسته نباشید.
    ببخشید میخاستم بپرسم که شما کدوم وزژن از لینوکس را استفاده میکنید؟

    پاسخ
    • محمد برغمدی
      مارس 29, 2017 در 20:42
      Permalink

      سلام و سلامت باشید.
      زمانیکه این آموزش رو نوشتم از توزیع Ubuntu استفاده میکردم الان هم از Ubuntu استفاده میکنم. 🙂

      پاسخ
  • مارس 31, 2017 در 15:06
    Permalink

    میخوام توربروزر نصب کنم این ارور میده
    The Tor Browser Bundle should not be run as root. Exiting.

    پاسخ
  • آوریل 16, 2017 در 06:14
    Permalink

    سلام ممنون میشم اگه لینک دانلود terminal بزارین خیلی تو سایت ها گشتم ولی پیداش نکردم

    پاسخ
    • محمد برغمدی
      آوریل 16, 2017 در 17:28
      Permalink

      سلام میثم جان
      ترمینال یک از ابزاری های اصلی لینوکس نیاز به دانلود نداره، کلید های Ctrl+Alt+F1 رو نگه دار بعد رمز عبور حساب کاربری تو بزن وارد TT1 میشی

      پاسخ
  • می 7, 2017 در 15:51
    Permalink

    سلام چرا در قسمت رمز در لینوکس من چیزی نوشته نمیشه میخوام یک برنامه نصب کنم گیر به پسورد داده ؟؟
    همش خطا میده . اون قسمت انگار غیره فعال شده !!!!

    پاسخ
  • می 7, 2017 در 23:52
    Permalink

    پیام خطا اینه
    student@labdoo-000010056:~$ cd Downloads/
    student@labdoo-000010056:~/Downloads$ sudo dpkg -i wine-1.8.6.tar.bz2
    [sudo] Passwort für student:
    student ist nicht in der sudoers-Datei. Dieser Vorfall wird gemeldet.
    student@labdoo-000010056:~/Downloads$
    من کلا مبتدی هستم ولی خیلی علاقه دارم. من پسورد یوزر اصلی رو ندارم فقط از یوزر student رو دارم من الان باید چکار کنم خوشحال میشم کمک کنید |؛

    پاسخ
    • محمد برغمدی
      می 8, 2017 در 00:34
      Permalink

      سلام علی جان
      فکر میکنم داره میگه حساب کاربری شما عضو هیچ گروه sudo ای نیست یعنی اینکه مجوز کافی برای نصب برنامه رو ندارید. (مثل حساب کاربری Guest در ویندو که محدودیت امنیتی داره)
      بعد شما دارید فایل tar.bz2 رو نصب میکنید، اول باید این فایل رو از حالت فشرده خارج کنید بعد اگر فایل setup با پسوند .deb یا .rpm داشت اون رو با دستور dpkg -i نصب کنید. یا اینکه معمولا این فایلها فقط نیاز به Extract شدن دارند نه چیز دیگه ای

      یک کار دیگه ای هم که میتونید انجام بدید اینکه بعد از extract کردن فایل فشرده با دستور cd وارد پوشه extract شده بشید بعد با دستور ls بررسی کنید و اگر فایل ی با نام install.txt یا install یا readme وجود داشت با استفاده از دستورات زیر شروع به نصب فایل کنید:
      xdg-open INSTALL
      sudo make install
      sudo checkinstall
      موفق باشید 🙂

      پاسخ
  • می 8, 2017 در 12:05
    Permalink

    dpkg: error processing package audio-recorder (–install):
    dependency problems – leaving unconfigured
    dpkg: dependency problems prevent configuration of gimp:
    gimp depends on libgimp2.0 (>= 2.8.20); however:
    Package libgimp2.0 is not installed.
    gimp depends on libgimp2.0 (= 2.8.20); however:
    Package gimp-data is not installed.
    gimp depends on gimp-data (= 2.8.0); however:
    Package python-gtk2 is not installed.
    gimp depends on libbabl-0.1-0 (>= 0.1.10); however:
    Package libbabl-0.1-0 is not installed.
    gimp depends on libgegl-0.3-0 (>= 0.3.0); however:
    Package libgegl-0.3-0 is not installed.
    سلام می خوام نرم افزار gimpرو نصب کنم این ارور ها رو میده

    پاسخ
    • محمد برغمدی
      می 14, 2017 در 11:48
      Permalink

      سلام محمد جان ببخشید بابت تاخیر در پاسخگویی
      اول از دستورات زیر استفاده کنید تا برنامه رو پاک کنید بعد دوباره برنامه gimp رو با اضافه کردن ppa به list توزیع تون نصب کنید:
      sudo apt-get autoremove
      sudo apt-get –purge remove && sudo apt-get autoclean
      sudo apt-get -f install
      sudo apt-get update
      sudo apt-get upgrade && sudo apt-get dist-upgrade
      sudo dpkg-reconfigure -a
      sudo dpkg –configure -a
      برای نصب هم از دستورات زیر استفاده کنید:
      sudo add-apt-repository ppa:otto-kesselgulasch/gimp
      sudo apt-get update
      sudo apt-get install gimp
      sudo apt-get install ppa-purge
      sudo ppa-purge ppa:otto-kesselgulasch/gimp
      موفق باشید

      پاسخ
  • می 13, 2017 در 20:22
    Permalink

    سلام.من میخوام نرم افزار gaussian رو اوبونتو نصب کنم بعد دستور sudo ارور زیرو میده.
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    E: Unable to locate package gaussian
    وقتی دستور sudo gedit /etc/apt/sources/list رو میزنم یه صفحه باز میشه؛ممنون میشم راهنماییم کنید الان باید چیکار کنم تا برنامه رو بتونم نصب کنم.

    پاسخ
    • محمد برغمدی
      می 14, 2017 در 11:39
      Permalink

      سلام
      به خاطر نبود برنامه gaussian در Repository توزیع تون با خطایی Unable to locate package مواجه شدید.
      باید اطلاعات (PPA) مربوط به Repository برنامه gaussian رو به همون فایل /etc/apt/sources/list اضافه کنید. یا اینکه برنامه رو به صورت دستی دانلود کنید و با دستور dpkg -i نصبش کنید.

      پاسخ
  • می 14, 2017 در 14:30
    Permalink

    salam khase nabashid mamnon az site khobeton , man chrome o nasb kardm ba in error movajeh shodm mamnon misham komak konin :
    google chrome can not be run as root
    please start google chrome as a normal user . if you need to run as root for development with the –no-sandbox flag.

    پاسخ
    • محمد برغمدی
      می 14, 2017 در 14:55
      Permalink

      علیک سلام
      از چه توزیعی استفاده میکنید؟
      برنامه Google Chrome رو نصب کردید اما میگه نمیتونید در حساب کاربری Root ازش استفاده کنید.
      باید Google Chrome رو با یک ویرایشگر متن مثل gedit باز کنید:
      gedit /usr/bin google-chrome
      سپس –user-data-dir رو در آخر فایل اضافه کن و فایل تون رو ذخیره کنید، مثلا:
      exec -a “$0” “$HERE/chrome” “$PROFILE_DIRECTORY_FLAG” \ “$@”
      –user-data-dir

      پاسخ
  • می 20, 2017 در 22:15
    Permalink

    سلام دوست عزیز من ns3 میخوام نصب کنم هر چکار میکنم پیام کد password to techno رو مینویسه لطفا راهنمای بفرمایید ….

    پاسخ
    • محمد برغمدی
      می 21, 2017 در 00:25
      Permalink

      سلام از چه توزیعی استفاده میکنید و اینکه ns3‌ رو برای چه زبانی میخواهید استفاده کنید:
      C++ یا Python یا …؟؟

      پاسخ
  • ژوئن 17, 2017 در 18:18
    Permalink

    سلام. وقت شما بخیر

    من چند روزی هست که درگیر نصب تولباکس kaldi روی اوبونتو ۱۶.۰۴ هستم. که باید دستور make رو طبق

    توضیحات تولباکس اجرا کنم. که عملیات به طور کامل اجرا شده اما در انتها متن زیر نوشته می شود

    arning: IRSTLM is not installed by default anymore. If you need IRSTLM
    Warning: use the script extras/install_irstlm.sh
    All done OK.
    من هم دستور extras/install_irstlm.sh آمده در بالا را تایب کرده و دستور اجرا شده و در انتها متن زیر می آید:

    منظور از متن زیر چیست؟ (***() Please source the tools/extras/env.sh in your path.sh to enable it)

    ***() Installation of IRSTLM finished successfully
    ***() Please source the tools/extras/env.sh in your path.sh to enable it

    ===========================================================
    ۲- چرا در ترمینال دستور vim sources.list را که تایب میکنم متن زیر را به من می دهد:

    The program ‘vim’ can be found in the following packages:
    * vim
    * vim-gnome
    * vim-tiny
    * vim-athena
    * vim-athena-py2
    * vim-gnome-py2
    * vim-gtk
    * vim-gtk-py2
    * vim-gtk3
    * vim-gtk3-py2
    * vim-nox
    * vim-nox-py2
    Try: sudo apt install

    وبا تایب دستور داده شده در بالا (sudo apt install <selected package) متن زیر را به من می دهد:

    bash: syntax error near unexpected token `newline'

    ===========================================================

    لطفا باسخ دهید چون چند وقتی است که درگیر این موضوع هستم.

    با تشکر

    پاسخ
    • محمد برغمدی
      ژوئن 19, 2017 در 01:04
      Permalink

      سلام ماهان جان
      جواب سوال دوم: به خاطر نصب نبودن برنامه vim پیغام مذکور شما نمایش داده میشه، شما میتونید بجای استفاده از دستور vim از برنامه gedit استفاده کنید.
      برای مثال:
      sudo gedit /etc/apt/sources.list
      برای نصب برنامه vim هم باید از دستو sudo apt-get استفاده کنید نه apt خالی برای مثال:
      sudo apt-get install vim
      جواب سوال اول: راستش رو بخواهید چیزی ازش سر در نیاوردم – ولی این چند تا لینک رو پیدا کردم شاید بدرد تون بخوره:
      آموزش نصب kaldi

      پاسخ
  • جولای 30, 2017 در 20:30
    Permalink

    سلام ببخشید من بعضی برنامه های گرافیکی مثل substance painter یا photoshop نصب کنم بعدش کرک میخاد درسته؟ کرکش از کجا گیر میاد منتظر جواب هستم مرسی :X

    پاسخ
    • محمد برغمدی
      جولای 31, 2017 در 16:13
      Permalink

      سلام
      از همون کرک های که برای ویندوز استفاده کردید میتونید استفاده کنید.
      البته باید بگم من کلا تا حالا این مورد رو تست نگرفتم، ولی برای PS همون فایل amtlib.dll رو اگر در پوشه نصب Photoshop بریزید مشکل کرکش کاملا برطرف میشه
      موفق باشید.

      پاسخ
  • آگوست 9, 2017 در 19:30
    Permalink

    سلام خدمت اساتید محترم
    مشکل من اینه که برنامه با دستور در ترمینال دانلود میکنم یعد اینکه سوال میکنه که نصب بشه یا نه میزنم که نصب بشه ولی همش ارور میده چی کار باید بکنم ؟

    پاسخ
    • محمد برغمدی
      آگوست 12, 2017 در 18:55
      Permalink

      سلام
      با چه دستوری برنامه رو میخواهید نصب کنید؟
      از کدوم توزیع لینوکس استفاده میکنید؟
      لطفا خطا رو هم ارسال کنید.

      پاسخ
  • آگوست 16, 2017 در 19:14
    Permalink

    سلام
    من از ابونتو 16.10 استفاده می کنم
    الان می خوام یه برنامه نصب کنم دستور نصبش تو فایل همراش به این صورت :
    To install GULP on most Unix/Linux machines :

    (1) Go to Src/
    (2) Type “make”
    (3) If the above fails – edit “getmachine” and correct the settings for your machine
    (4) Set the following environment variables to indicate where the program files can
    be found:

    GULP_LIB The location of the Libraries directory
    GULP_DOC The location of the Doc directory
    الان موقع نصب این اتفاق میوفته :

    a@ubuntu:~/Desktop/gulp-4.4/Src$ “make”
    /bin/sh getmachine gulp
    make[1]: Entering directory ‘/home/a/Desktop/gulp-4.4/Src/Linux’
    gfortran -O1 -I.. -DFLUSH -c ../datatypes.F90
    make[1]: gfortran: Command not found
    لطفا بهم بگید مشکل کجاست خیلی احتیاج به نصب این برنامه دارم
    makefile:277: recipe for target ‘datatypes.o’ failed
    make[1]: *** [datatypes.o] Error 127
    make[1]: Leaving directory ‘/home/a/Desktop/gulp-4.4/Src/Linux’
    mv: cannot stat ‘gulp’: No such file or directory
    Makefile:189: recipe for target ‘gulp’ failed
    make: *** [gulp] Error 1

    پاسخ

پاسخ دهید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *